You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, November 18th 2008, 4:23pm

To show or not to show progress indicators

I use only two resoluition for my panos: a small for showing in an iframe on the webpage and a bigger one for the fullscreen view. I accomplish that using the Multires-tool:

http://fvlmedia.dk/flashdyn.htm

But I have some issues:

It's OK to have the progress load and wait showing up when loading new panos, but I don't like them to show while rotating. I've tried different solution: 1. Setting decode=all and downlod=all 2.switching off the progress load and wait in fullscreen. 3. Both.

The first seams to work best, but on some overloaded systems it sometimes freeze while loading a new pano (My fullscreen panos are no bigger than 6000x3000!) - and it takes some ektra time decoding before fading into the new pano

With the second and third method people get no indication on what's going when laoding a new pano.

So my question is there another way to do this?

2

Tuesday, November 18th 2008, 10:01pm

Hi,

maybe a solution...
... switch off the progressbar and the waiting loop when switching to fullscreen,
and enable it again when loading the next pano...

e.g. - disable the progressbar and the waiting loop:

Source code

1
2
set(progress.showload,none);
set(progress.showwait,none);


e.g. - enable the progressbar and the waiting loop:

Source code

1
2
set(progress.showload,bar());
set(progress.showwait,loopings());


best regards,
Klaus

3

Wednesday, November 19th 2008, 12:04pm

Well, I think this is the best I can do. I've put the show and hide progress action in the combox.xml (which I include in the 1st loaded pano.xml) and sett download=all, but leaving decode at the default "auto". Now it does what I want most of the time. Shows the progress while loading a new pano, but not while loading and decoding the tiles on rotating. Only times it fails is when going from lo-res to fullscreen.

Quoted


<krpano version="1.0.7">

<plugin name="combobox"
url="%SWFPATH%/plugins/combobox.swf"
align="lefttop"
x="10"
y="10"
width="150"
keep="true"
onloaded="action(setupitems);"
/>

<action name="setupitems">
removeall();
additem(Hjalet, action(showpr);loadpano(east_t.xml,NULL,KEEPALL,BLEND(1));wait(blend);action(hidepr); );
additem(Spisestue, action(showpr);loadpano(spisestue.xml,NULL,KEEPALL,BLEND(1));wait(blend);action(hidepr); );
additem(Bar og Pool, action(showpr);loadpano(bar.xml,NULL,KEEPALL,BLEND(1));wait(blend);action(hidepr); );
</action>

<action name="hidepr" >
set(progress.showload,none);
set(progress.showwait,none);
</action>

<action name="showpr" >
set(progress.showload,bar());
set(progress.showwait,loopings());
</action>

</krpano>