You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, June 7th 2009, 1:22pm

Problems viewing my panos

Hi there

I have recently pruchased the unlimited domains krapno licence. I have managed to get this licence working perfectly on my local web server, but as soon as I load it onto the internet, problems start occuring; nameley the following error:

SecurityError: Error #2060: Security sandbox violation: ExternalInterface caller http://plugin.digitaltours.co.za/krpano/krpano.swf/[[DYNAMIC]]/1 cannot access http://demo.digitaltours.co.za/experienc…coachmancottage.
at flash.external::ExternalInterface$/flash.external:ExternalInterface::_initJS()
at flash.external::ExternalInterface$/addCallback()
at krpano/::setup_extern_interfaces()
at krpano/::startup_stage5()
at krpano/::startup_stage3()
at krpano/::startup_stage2_parseexternkey()
at flash.events::EventDispatcher/flash.events:EventDispatcher::dispatchEventFunction()
at flash.events::EventDispatcher/dispatchEvent()
at flash.net::URLLoader/flash.net:URLLoader::onComplete()

This error occurs when I try to access the following site:

http://demo.digitaltours.co.za/experienc…coachmancottage
xml file URL: http://demo.digitaltours.co.za/Trout%20H…hmancottage.xml
settings sml URL: http://demo.digitaltours.co.za/settings.xml

Currently there seems to be an error with my setting.xml file, but even when I removed the include for this file from another pano xml file, I still get the same error.

Please assist

Regards
Darren

VN2009

Professional

Posts: 1,336

Location: Duluth MN

  • Send private message

2

Sunday, June 7th 2009, 4:42pm

check your .html file make sure that it is pointing to the correct lcoation of krpano.swf. i had that happen to me last night when i was making templates for various projects. i would get a blank screen if the .html file was incorrect.

3

Monday, June 8th 2009, 7:48am

the .html (in this case it is in fact a .php file) is pointing to the correct flash resource. I have checked the addresses of every resource that the page uses, yet I still am unable to view the pano.

I have tried configuring a cross domain file in the root domain of my flash resource, but this doesnt seem to help. The crossdomain.xml file can be found here:

http://plugin.digitaltours.co.za/crossdomain.xml

4

Monday, June 8th 2009, 7:50am

On another note, the krpano flash swf file is located here http://plugin.digitaltours.co.za/krpano/krpano.swf

5

Monday, June 8th 2009, 2:34pm

Hi,

please check this file:
http://plugin.digitaltours.co.za/crossdomain.xml

try changing it to:

Source code

1
2
3
<cross-domain-policy>
  <allow-access-from domain="*"/>
</cross-domain-policy> 


best regards,
Klaus

6

Tuesday, June 9th 2009, 7:37am

Hi Klaus

OK, I have changed the crossdomain.xml to the code mentioned above.

Please will you browse to the following address and have a look at the problem that I am having

http://demo.digitaltours.co.za/experienc…way&pano=bigdam


As you can see, the flash loads up, as when I press 'O' the console comes up showing the registration details etc of the plugin, but I still cannot view my panos.

Any further ideas?

7

Tuesday, June 9th 2009, 3:05pm

Try reloading the license file directly from the original source that you saved it to when you purchased it. I find when I move files a bit, I occasionally get the black screen without the redirect to KRpano website. I think it may be some type of security feature that keeps others from being able to steal your license. Or I could be totally off base with this statement.

I usually load the license file where I intend to store it on the server and then rename it as I want it(I deal with an iis server) or you can keep it in whatever form you use.

Jarredja

8

Tuesday, June 9th 2009, 11:46pm

Hi,

the basic problem here is the cross-domain access,
you see that also on the error message: "SecurityError" - "cannot access"

Quoted

SecurityError: Error #2060: Security sandbox violation: ExternalInterface caller http://plugin.digitaltours.co.za/krpano/krpano.swf/[[DYNAMIC]]/1 cannot access http://demo.digitaltours.co.za/experienc…coachmancottage.
I see you are using the 1.0.6 version, please try using a newer one (1.0.7 or 1.0.8),

best regards,
Klaus

9

Wednesday, June 10th 2009, 7:21am

Hi Klaus

I downloaded and installed the 1.0.8b version of krpano.swf onto my web server. When I tried to load a pano however, the screen was black and when I right clicked for the menu items, the only items that were there were the flash 10 item and a greyed out 'movie loading' item.

I then downloaded and installed the 1.0.7 version. This version is doing the exact same thing as the 1.0.6 version. No loading of the pano itself, but just the flash plugin. It almost seems as though the loading of the flash plugin works correctly, but then it doesnt want to load any content,not even the loading animation.

Further help will be appreciated
Darren

10

Wednesday, June 10th 2009, 7:35am

One other thing that I would like to mention to help the debugging process, is that I can view a standard pano from the krpano.xml file in the root .swf directory.

Check it out here: http://plugin.digitaltours.co.za/krpano/krpano.swf

11

Wednesday, June 10th 2009, 8:45am

Hi,

okay, I have analyzed your example once more
the javascript embedding code was also from the other domain => the next problem,

by default only access to the "sameDomain" is allowed, have a look:
http://kb2.adobe.com/cps/403/kb403183.html

try adding this code to the HTML:

Source code

1
so.addParam("AllowScriptAccess","always");


best regards,
Klaus

12

Thursday, June 11th 2009, 8:20am

Thanks Klaus,

The allow scripts parameter worked like a dream ;)