You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Saturday, October 27th 2012, 1:51pm

removehotspot error

Dear Klaus, dear community,

I ran into the following error today, and can't seem to find what's wrong here:

DEBUG: set(hotspot[bullet_533].crop, 32|0|32|32);delayedcall(2.0,removehotspot(bullet_533));
ERROR: remove - unknown array item - hotspot[bullet_533]

the funny thing is, that the crop works perfectly, I can see it, and AFTER that the hotspot doesn't get removed. I mean I know this message could be there if I tried to remove the same hotspot multiple times, but no, it just stays there on the screen, so actually it doesn't get removed, not a single time.

Any idea why does the crop work (so the hotspot name is perfectly valid), but the removehotspot call doesn't?

Thanks for any help!


Saturday, October 27th 2012, 3:23pm

2 seconds it's very long in the delayedcall try put another time like 0.2


Saturday, October 27th 2012, 3:54pm

It seems to work for me. Can you show your example?

Similar threads