You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Phil

Trainee

  • "Phil" started this thread

Posts: 97

Location: Texas

  • Send private message

1

Saturday, February 9th 2013, 8:02pm

HTML5 Error Message: videoplayer.js - loading failed! (404)

The video plays fine with Flash but in a HTML5 browser I receive the "videoplayer.js - loading failed! (404)" error.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
		<hotspot name="video1" url="plugins/videoplayer.swf" 
				 alturl="videoplayer.js" 
				 ath="227.4" atv="-29.9" distorted="true" rx="-19.75" ry="2.50" rz="-1.17" width="640" height="360" scale="0.577" 
				 buffertime="0.1"
				 directionalsound="false"
				 ignoremetadata="false"
				 iscomplete="true"
				 isvideoready="true"
				 loop="true"
			 	outofrangevolume="0"
				 pausedonstart="false"
				 posterurl="video/videoposter.jpg"
				 range="90"
				 rangefalloff="2"
				 videourl="video/video.mp4|video/video.webm|video/video.flv"
				 volume="0"
				 onclick="togglepause();"
				 />


What's missing?

Thanks,
Phil

Phil

Trainee

  • "Phil" started this thread

Posts: 97

Location: Texas

  • Send private message

2

Saturday, February 9th 2013, 8:08pm

Nevermind...I found the error seconds after asking the question.
Changed alturl="videoplayer.js" to alturl="plugins/videoplayer.js"

Phil