You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, June 15th 2009, 5:57pm

Security Error

I'm getting a security error on my global xml file when i try to open my virtual tour...

http://radialimages.com/virtualtour/tastingauction/welcome/

the strange thing is that everything was working awesome locally, but once i put it up on the server nothing works. any ideas? thanks!!

-erik

This post has been edited 1 times, last edit by "RadialImages" (Jun 15th 2009, 6:14pm)


Shanti

Intermediate

Posts: 301

Location: Puerto Vallarta

Occupation: Web Developer

  • Send private message

2

Monday, June 15th 2009, 6:23pm

In your XML you have this...

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
<plugin name="radar" url="C:\Documents and Settings\University Events\Desktop\tastingauction\plugins
/radar.swf" 
           heading="210" 
           fillcolor="0xffffff" 
           fillalpha="0.8"
           linecolor="0x000000"
           linewidth="1"
           linealpha="0.5"
		   align="lefttop"
		   x="157"
		   y="143"
		   width="80"
		   height="80" 
           />


the URL is pointing to a local file in your C drive... :) since this is a security concern, you get that error, change it accordingly to your web server e.g

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
<plugin name="radar" url="radar.swf" 
           heading="210" 
           fillcolor="0xffffff" 
           fillalpha="0.8"
           linecolor="0x000000"
           linewidth="1"
           linealpha="0.5"
		   align="lefttop"
		   x="157"
		   y="143"
		   width="80"
		   height="80" 
           />

3

Monday, June 15th 2009, 6:24pm

ahhh, too easy. i looked through so many times and i thought i changed everything to the server links. thanks!


edit. i fixed the welcome.xml, and i did a search for "C:" in my global.xml but there is nothing pointing locally. it still is giving me the security error. *blink*

Shanti

Intermediate

Posts: 301

Location: Puerto Vallarta

Occupation: Web Developer

  • Send private message

4

Monday, June 15th 2009, 6:38pm

if you use this url the pano loads.

http://www.radialimages.com/virtualtour/…uction/welcome/

and this is because you don't have a crossdomain.xml file

Source code

1
2
3
4
<?xml version="1.0"?>
<cross-domain-policy>
  <allow-access-from domain="*.radialimages.com" />
</cross-domain-policy>


put this file in the root of your server.

or just change the global.xml and all of the other paths to use relative and not absolute paths

e.g

Source code

1
url="http://www.radialimages.com/etc/etc/global.xml"


change to

Source code

1
url="global.xml"


but the crossdomain.xml is the best solution

5

Monday, June 15th 2009, 6:48pm

amazing. thanks shanti!