You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, March 29th 2013, 10:01am

tools 1.16 / zoom out

hallo ...

wenn ich mit den neuen tools 1.16 ein MAKE PANO MULTIRES erzeuge, kann ich mit der standardmässigen voreinstellung
anschliessend mit dem zoom out bis auf ein quadratisches bild herauszoomen, was ein sehr unerwünschter effekt ist....
( siehe foto anbei ) ...

bisher hatte ich in der steuerungs-xml folgenden eintrag und alles war gut:
<view hlookat="0" vlookat="0" maxpixelzoom="1.0" limitview="auto" />


diese zeile funktioniert mit dem neuen player aber nicht mehr, muss ich hier etwas ändern ?

fragt
mthrills | Hans
mthrills has attached the following image:
  • kr_zoom_out.jpg

2

Friday, March 29th 2013, 10:12pm

Hi,

Quoted

bisher hatte ich in der steuerungs-xml folgenden eintrag und alles war gut:
<view hlookat="0" vlookat="0" maxpixelzoom="1.0" limitview="auto" />
Keine dieser Einstellungen dort hat etwas mit dem maximal erlaubten fov Wert zu tun.
Siehe hier die fovmax Einstellungen:
http://krpano.com/docu/xml/#view


Was sich geändert hat ist, das in den vorherigen Versionen war der fov Wert im 'nicht-Fisheye-Modus' immer automatisch auf maximal 170.0 beschränkt wurde, auch wenn der eigentliche fovmax Wert größer war (per Default 179.0).

Da in HTML5 aber fov Werte größer als 170 auch noch fehlerfrei dargestellt werden können, wurde dieses automatische Limit entfernt, damit sich die Flash und HTML5 Viewer gleich verhalten.

D.h. wenn der Zoom-out beschränkt werden soll, einfach eine fovmax Einstellung hinzufügen,
z.B.

Source code

1
<view hlookat="0" vlookat="0" maxpixelzoom="1.0" limitview="auto" fovmax="170" />


Ich werde in der nächsten Release dies in der default.xml auch hinzufügen.

Schöne Grüße,
Klaus

martyhr

Intermediate

Posts: 337

Location: CZ

  • Send private message

3

Saturday, March 30th 2013, 7:20pm

I found the same behavior.
After MAKE PANO(Multires) i get the cube( see the picture above) with maximal zoom out.

But if I switch to fisheye view and then back to normal, the max zoom out is OK.
*cry*

4

Sunday, March 31st 2013, 5:31pm

Hi,
After MAKE PANO(Multires) i get the cube( see the picture above) with maximal zoom out.
That's correct and normal, there is no fovmax setting for limiting the view by default in the xml and the new version doesn't limit to view anymore to 170 in normal viewing mode.

To 'correct' it, just add a fovmax setting - e.g.:

Source code

1
<view ... fovmax="150" />


But if I switch to fisheye view and then back to normal, the max zoom out is OK.
Yes - see view actions in the xml - the normal action will set the fovmax setting to 150.

Best regards,
Klaus

martyhr

Intermediate

Posts: 337

Location: CZ

  • Send private message

5

Sunday, March 31st 2013, 10:05pm

Thanks for making it clear. *smile*

6

Thursday, April 4th 2013, 3:49pm

... besten dank für die hilfe ...

hallo Klaus ....

... wieder einmal : vielen dank ... ich konnte meine files jetzt alle auf den neuesten stand bringen ...

grüsst

mthrills | Hans