You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, April 4th 2013, 11:54am

Progress suddenly visible and not able to hide it when upgrading from 1.0.8.15 to 1.16.1

When I upgraded krpano from 1.0.8.15 to 1.16.1 and updated the xml to the right version number, I get the progress bar back that I specifically disabled using <progress showload="none" showwait="none" />.

I am using a global xml and pano specific xml's in all which I pasted the above xml to no avail. The progress bar used to be disabled by only having the progress settings in my global xml.

What must I do to hide the progress bar again or is there a bug in 1.16.1?

2

Thursday, April 4th 2013, 1:51pm

Resolved.. It was a caching issue.

3

Friday, April 19th 2013, 3:53pm

Hello! I have this problem with progress bar too, and it's not сaching! After upgrading krpano.swf from 1.0.8.15 to 1.16.1, I can saw only default progress bar with wait animation on each of old panos.
The old showload="bar(center,400,50,0,140,shaded,0x000000, 0xDDDDDD,0xAAAAAA)" don't understanding, and even none/none do not hide a default bar.
I have tested a copies of all files with new names => it's not caching.
What the problem it can be?

4

Friday, April 19th 2013, 7:05pm

Hi,

in the 1.16 version the default value for the showwait/showload is now 'none'.

That means when loading other panos/scenes without MERGE or KEEPALL or KEEPPROGRESS flag, the current progress setting will be always set back to the default 'none' setting.

Best regards,
Klaus

5

Saturday, April 20th 2013, 6:34am

Thank You, Klaus, but I have not load other panos. Only one pano, and always default bar (not 'none').
But I found a mistake.


<krpano version="1.16">
<include />

<include />
<include />
...
<include />
</krpano>
if in any of include xml's I forgot to change old version in the head (<krpano version="1.0.8.15">), when we have look suddenly visible progress bar. Nice:)
Thank You, for your time!
http://sovyata.ru/panorams/sorevnovaniya…gk-avalman.html - it's working!)