Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

rocktopus

Anfänger

  • »rocktopus« ist der Autor dieses Themas

Beiträge: 5

Wohnort: Pune

Beruf: Software Engineer, Biker, Guitarist

  • Nachricht senden

1

Freitag, 19. April 2013, 14:09

FATAL: XML loading error (IO error) in FLASH ONLY.

Hi,

Everything was working fine for me on version 1.0.8.15

I upgraded to version 1.16.2 and I started getting this error:
FATAL: http://www.xyz.com/abcd.xml loading error (IO error)

This happens in FLASH ONLY. *cursing*
The most confusing thing is when I disable flash and load HTML5 version it loads up and works perfectly. *wacko*

Please help. Want to get the tour working in FLASH also.

rocktopus

Anfänger

  • »rocktopus« ist der Autor dieses Themas

Beiträge: 5

Wohnort: Pune

Beruf: Software Engineer, Biker, Guitarist

  • Nachricht senden

2

Montag, 22. April 2013, 06:29

No help?

Come on guys this is critical for me. No help? or is there some thing obvious that I am missing here?

Tuur

Erleuchteter

Beiträge: 3 021

Wohnort: Netherlands

Beruf: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Nachricht senden

3

Montag, 22. April 2013, 15:41

it looks like you have a mistake in your xml that is called by the flash..
check your xml!

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

rocktopus

Anfänger

  • »rocktopus« ist der Autor dieses Themas

Beiträge: 5

Wohnort: Pune

Beruf: Software Engineer, Biker, Guitarist

  • Nachricht senden

4

Mittwoch, 24. April 2013, 08:44

I validated the XML using all modern updated browsers. They show no errors.
Its works with the older krpano FLASH version (till 1.0.8.15) and every HTML5 version.
The problem is just with the latest krpano 1.16 FLASH ONLY.

Can anyone give me a hint that what can go wrong in XML with the latest krpano 1.16 FLASH.
Is there something else instead of XML that has to be taken care of?

The main question is how do I debug this issue? I need help with that.

5

Mittwoch, 24. April 2013, 16:35

Hi,

I have to say I have no idea what could cause an xml error in Flash-only...
Therefore - can you please show the xml file?

Btw - 'IO Error' is the short form of 'Input/Output Error' and means that the loading itself was not possible.

Best regards,
Klaus

rocktopus

Anfänger

  • »rocktopus« ist der Autor dieses Themas

Beiträge: 5

Wohnort: Pune

Beruf: Software Engineer, Biker, Guitarist

  • Nachricht senden

6

Donnerstag, 25. April 2013, 08:47

I got it working. *g*

I was encoding the URL using JavaScript function "encodeURIComponent()" this worked till version 1.0.8.15.
When I upgraded to 1.16.2, it works only when I remove the function.
Klaus, you have managed that already in 1.16 version swfkrpano.js Thanks. *thumbup*

Thank you Tuur and Klaus for your help. *thumbsup*