You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, July 21st 2013, 12:00am

html5 support with firefox ver 22 - does it work?

html5 virtual tours do not appear to work with firefox ver 22. This was following a clean install of firefox ver 22 with no flash installed on windows 7 laptop.

I tried with several of my virtual tours and got following message:

ERROR:

Adobe Flashplayer 10.1 (or higher) or a
HTML5 Browser with CSS 3D Transforms or WebGL support are required!


This is using krpano 1.16.3 2013-05-06, I tried using older version of krpano 1.0.8.15 2012-08-10 and VT is displayed but panels are jumbled up.

I also tried Klaus's demos for example http://krpano.com/tours/weingut/ and got same error message.

Any ideas, or am I doing something wrong as documentation indicates this should work.

Thanks
Tim

lrwieland

Beginner

Posts: 26

Location: Austin, TX USA

Occupation: Officially retired, but really a full time panographer

  • Send private message

2

Monday, July 22nd 2013, 4:11pm

Seems to be working fine for me, using Firefox v 22 and KRPano 1.16.5, running on OS X Mountain Lion. I have the HTML5 parameter on the embed command set to "only"

3

Wednesday, July 24th 2013, 7:46pm

Hi,

that means your Firefox Browser isn't able to use Hardware acceleration.
I think with the latest Firefox Update 22 this was happening on several systems, it seems several older GPU drivers were black-listed in that Firefox version...

Please see this post here for more details and solutions:
krpano 1.16

Best regards,
Klaus

4

Thursday, July 25th 2013, 12:34am

Firefox 22

Thanks Klaus

I checked firefox and you are right:

Direct2D Enabled

Blocked for your graphics driver version. Try updating your graphics driver to version 257.21 or newer.

GPU Accelerated Windows

0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer.

I will update the drivers and retest.

Appreciate the fast response.

cheers

Tim

5

Thursday, July 25th 2013, 12:45am

Firefox 22 and html5 issues

As per Klaus's suggestion, I did the following:

  1. enter the url - about:config - in Firefox
  2. enter 'webgl' in the search/filter field
  3. enable the webgl.force-enabled setting by double clicking it (set to true)
  4. restart the browser and try viewing the pano again
  5. if still not working:
  6. enter 'layers' in the about:config search/filter field
  7. enable the layers.acceleration.force setting by double clicking it (set to true)
  8. restart the browser and try viewing the pano again

And got firefox 22 to work with html5 on windows 7 laptop *smile*

regds

Tim