You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

poalpina

Beginner

  • "poalpina" started this thread

Posts: 38

Location: Trento - Italy

  • Send private message

1

Friday, October 4th 2013, 10:24pm

the tilesize should be 512px!

I put on line on my website in the last 5 year more then 150 pano 360x180 and more then 50 HDimage.
Now I'm working to pass to the HTML5 version, and I had the fatal error: "No HTML5 compatible image available"
I'm quite sure that the problem is the tilesitze: in the past I used values like 700x700 720x720 , 800x800 , 890x890 , 900x900... I'm right ?
This "problem" will come back with the next 1.17 final version?
I'll have to re-upload all my photos ? *unsure*

. xml code
<krpano version="1.16">

<prerelease watermark="false" />

<include url="skin/defaultskin.xml" />

<view hlookat="147" vlookat="30" maxpixelzoom="1.0" fovmax="150" limitview="auto" />

<preview type="CUBESTRIP" url="pano123.tiles/preview.jpg" />

<image type="SPHERE" multires="true" tilesize="625">
<level tiledimagewidth="10000" tiledimageheight="5000">
<sphere url="pano123.tiles/l4_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="5000" tiledimageheight="2500">
<sphere url="pano123.tiles/l3_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="2500" tiledimageheight="1250">
<sphere url="pano123.tiles/l2_%0v_%0h.jpg" />
</level>
<level tiledimagewidth="1250" tiledimageheight="625">
<sphere url="pano123.tiles/l1_%0v_%0h.jpg" />
</level>
</image>

</krpano>

and .html code


....
<td colspan="10" ><div align="center"></div>

<script src="swfobject/krpano_emb.js"></script>

<div id="pano" style="width:100%; height:100%;">
<noscript><table style="width:100%;height:100%;"><tr style="valign:middle;"><td><div style="text-align:center;">ERROR:<br/><br/>Javascript not activated<br/><br/></div></td></tr></table></noscript>
<script>
embedpano({swf:"swfobject/krpano_emb.swf", xml:"pano123.xml", target:"pano", html5:"auto", passQueryParameters:true});
</script>
</div>
.......

tonesh

Trainee

Posts: 69

Location: Rome

Occupation: Photographer

  • Send private message

2

Saturday, October 5th 2013, 7:21pm

Ciao Poalpina,
how do you get the tiles? Don't you use krpanotools?
I assume that you are using the new JS (in preview) so to test multi resolution on Html5, and I see that your image type is SPHERE,
and not CUBE as default for the krpanotools output.
It could be that problem, and not the tile size... (Klaus says that is "preferred to have that size, not that is nota allowed)...in this case you have to reprocess all your images ... *sad*
btw I reprocess about 250 panos last week to make them compatible with html5... and it was not so bad ;-) krpanotools makes it all automatic... and where I had actions and
specific layers, well yes, had to copy/paste a lot.

Toni

poalpina

Beginner

  • "poalpina" started this thread

Posts: 38

Location: Trento - Italy

  • Send private message

3

Saturday, October 5th 2013, 9:34pm

Ciao Tony

"and I see that your image type is SPHERE,
and not CUBE as default for the krpanotools output...
in this case you have to reprocess all your images"

Thanks a Lot
Now all is clear,

"Only cubical- and flat-multiresolution panos are supported at the moment!" by Klaus

Maybe I can take as good the HD partial panos,
those were flat

"I reprocess about 250 panos last week "
really , How long did it take you ?
first of all to upload on the net all panos ?

Matteo

Però a Te il grazie lo scrivo anche nella nostra lingua:
grazie

tonesh

Trainee

Posts: 69

Location: Rome

Occupation: Photographer

  • Send private message

4

Sunday, October 6th 2013, 1:19am


"I reprocess about 250 panos last week "
really , How long did it take you ?
first of all to upload on the net all panos ?

ehm, a week *g*
while uploading a project I was reprocessing the next one.
But it took a lot of time to correct stupid mistakes.
Some old projects where containing some unacceptable code: all due the fact that two terms can't be written without a space.
EX.:

Source code

1
<layer name="xyz" visible="false"align="center" />

there is no space between visible="false" and align="center".
This is ok for flash but gives fatal error on html5.
Sometimes very difficult to find *cry*

maybe someone can explain me how to debug xml for html5
thanks in advance

Toni

Alexey Tkachenko

Professional

Posts: 737

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

5

Sunday, October 6th 2013, 11:58am

I always just drag and drop the xml file onto any browser (Opera or Chrome) and the browser shows any errors. If, at last, it opens the xml, then it will be parsed by the browser correctly in html5.
Regards,

Alexey

tonesh

Trainee

Posts: 69

Location: Rome

Occupation: Photographer

  • Send private message

6

Sunday, October 6th 2013, 2:14pm

Thank you Alexey!
dropping the xml onto Chrome gives the error and, most important, the number of the line and column where the error is.
I was just using the iPad/iPhone simulator to test html5 and sometimes Safari with defined user agent, but then had to check it manually.

Thanks! *thumbsup*

Toni

poalpina

Beginner

  • "poalpina" started this thread

Posts: 38

Location: Trento - Italy

  • Send private message

7

Monday, October 7th 2013, 10:55pm

Quoted

gives the error and, most important, the number of the line and column where the error is
very good, thanks lot *thumbsup*

poalpina

Beginner

  • "poalpina" started this thread

Posts: 38

Location: Trento - Italy

  • Send private message

8

Tuesday, October 8th 2013, 8:41am

M.arco S.tucchi (www.marcostucchi.com)
sended me just yesterday this link below, very useful
to check the html5 code

http://validator.w3.org/check