Videos do not loop on iOS

  • Hi guys

    Anybody has some experience with 360 videos on ios (8.1)?
    I am loading a krpano viewer to UIWebView instance. The video plays fine, I can control it and all. The only problem seems to be that the video doesn't loop. I have tested it in the browsers (PC) and all seem fine there. For testing purposes I use one of the videos from the krpano website (the one with Dubai).
    I also tried to fire onvideocomplete but it doesn't work either (looping is set to false in that case, of course). Seems like the video end is never reached? But why?

    The xml is pretty simple:

    Any ideas? Thanks a lot!

    EDIT: tested on the following: iphone simulator - doesn't loop. iphone 6 with 8.2 - doesn't loop. iphone 6 with 8.3 - doesn't loop. ipad 3 with 8.3 - does loop (???). Actually you don't even have to embed the videos and load them to the webview. Just open the videos page examples here on in safari on iphone, it behaves the same.

    Edited 2 times, last by Fygo (April 27, 2015 at 4:41 PM).

  • Hi,

    there was an iOS bug related to the video buffering (the OS reports wrong states).

    Please try the latest 1.19 pre-release 2 version. This version contains a workaround for this bug, there the looping should work.

    Best regards,

  • Loop doesn't work for me on iPhone 6 with 1.19 pre-release2 into all these plugin cases :


    And also when updating loop attribute and/or onvideocomplete event into the scene.onstart event.

  • Hi,

    I've finished the analyzing of the video looping problem - the problem seems to be related to iOS and the video itself. From krpano and Javascript side everything is correct - the video playback positions and the rendering itself is all correctly.

    That means the reason why the video frame doesn't get updated is on iOS side and there it might depend on the video and its encoding settings...

    Best regards,

  • klaus,

    I tried 1.19 version as well and I can't get it to loop in iOS. But even if that fixed it, it turns out I can't upgrade from 1.18 because I have some plugins I'd have to rewrite and man not be possible, especially in time.

    It could be an issue with encoding like you mentioned...

    I'm in dire need to get loop on iOS and trying to figure out a way to to achieve it perhaps using with binding plugin events. Don't really care how, I'd event be happy with a hack.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!