(SOLVED) VR mode starts distorted, Settings crash the first time (tested on multiple iOS devices)

  • When VR mode is entered for the first time on a new device, this happens: very very strong zoom? *blink* When I try to go to settings, the tour freezes. Next time, VR mode is still distorted, but in the second or third attempt, a new device can be chosen and it works from then on.
    Some kind of havesettings error? Thanks!!!!

    Edited once, last by MIshaPetla (June 11, 2019 at 1:54 PM).

  • I don't think the problem can be solved by adding another device to
    the database; I'm running the tour as a standalone app, for ios and
    android, so external sources, in this case a database, are unavailable.
    The problem exists on all newer iphones (I am testing with iPhone
    Simulator and Xcode).
    Potential solutions I think are:

    • tweaking onunknowndevice parametres in index_core_vr. xml
    • disabling default VR "device-blank", or setting one of options as default
    • creating
      a settings file in advance, that way havesettings would return true.
      Only "blank" creates the problem; or not having a settings file

    What do you guys think?

    Add this to onentervr, in webvr.xml or index_core_vr.xml. And remove ask user for screensize, and if sentence on onunknowndevice.

    Not sure if all of this is needed, but it does the trick for me. I'm guessing the empty cache used to crash vr settings, now something gets written; no longer empty:)

    copy(hs, vrheadsets.headset1);

    copy(vrs, webvr.vrsetup);


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!