[RESOLVED] Krpano embedded with Iframe on sub-domain (https) not working on Android device

  • Hi,

    I have made search for hours on this problem...
    I'm using PTP 2.5.14 & KRPano 1.19-pr16
    If my tour is in my domain principal, everything works like charm embedding the tour with an iframe.
    What i'd like to do is hosting my tour in a sub-domain, someting like https://tour.mydomain.com and embed it this an iframe.
    I've made lots of tests, and every time VR mode button is inactive on Android device (Samsung internet, firefox and Chrome include).

    But, it's amazing to see that everythings works fine in GearVR (same device, Galaxy S8). Everything is fine on desktop (mac&PC).
    I have tested with Amazon S3 hosting too... same problem... :(
    I've read that the problem comes with last version of Chrome, and CORS configuration.

    Do you have an idea to pass thru this problem? Or it's only a sad reality?
    Thanks in advance, have a good day, or night...

    Edited once, last by Volkodlak (March 4, 2020 at 11:57 AM).

  • Hi,

    Thanks for the response.
    I've tried, but it doesn't work, i used this iframe:

    <iframe src="https://vtours.mydomain.com/clients/me/GEN" 
    frameborder="0" allowvr="yes" allow="vr; xr; accelerometer; 
    magnetometer; gyroscope; autoplay;" allowfullscreen 

    I'm embedding it into a wordpress site hosted at https://mydomain.com
    Everything works fine if the tour is in the main domain.

    Just thinking this will never work *cry*
    In fact, i don't understand why it works in gear vr with oculus browser, and doesn't work with other Androïd browsers.

    Edited 2 times, last by Volkodlak (March 4, 2020 at 2:51 AM).

  • Hi,

    What type of SSL certificate did you install? You would need a Wildcard SSL Certificate to cover the sub-domain. Can you reach the tour via https at the sub-domain?



  • Hi,
    I'm using a wildcard ssl certificat from let's encrypt.

    Everything's allright when calling the tour directly from his https adress on the sub domain.
    I've tried to use it from another web site, and the problem is the same . And, i yes, i've got same problem from amazon s3 bucket.
    Maybe a problem with Let's encrypt certificat?
    Thanks for your help.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!