Beta 9, Scenes setting %CURRENTXML%

  • I'm having a problem with the new Beta 9.

    If I load one scene i.e. 'pier' in an xml document, i.e. street, and then use loadpano to access a new scene i.e. exterior in a new xml document i.e. cafe it's fine. But if I then attempt to load the previous scene (street) I get an error that the scene xml file cannot be loaded because it's hasn't set the new xml file (street) as %currentxml% and is still recognising the previous XML doc, cafe as the current XML. But then it does load anyway but the error stays showing.

    This may have been happening on the previous version but it didn't show an error.

    Is there a way to define the currentxml? Or is this a bug?

  • Hi viewinz,


    Is there a way to define the currentxml?

    Perhaps you can use the basedir attribute of the <krpano> node:<krpano>

    base directory for the loadpano action commands.
    this can be a relative or a absolute path,
    the path can include this placeholders:

    • %FIRSTXML% - path of the first loaded xml file
    • %CURRENTXML% - path of the current loaded xml file
    • %SWFPATH% - path of the swf file
    • %HTMLPATH% - path of the html file

    the defaultvalue is %FIRSTXML%, that means the paths of all all following loaded XML files by the loadpano() action are relative to the first loaded XML file.


  • Michel, thanks for that - I think I've tried that but will look at it again.

    Klaus, this is in regard to that email I sent with error, this is only happening on the new version. And yes it is trying to go from scene to scene in to different XML documents. It works fine if you go from XML A scene street, to XML B scene house, but if you then try to go from XML B scene house to XML A scene street you get an error cannot find scene street in XML B. But then it loads scene street anyway! But the error remains on the screen.

    I do it this way..

    loadpano(../../house.xml, MERGE, blend(1));

    As I said before it works fine one way but not the other!

    EDIT: Fixed.. removed the %currentxml% from scene urls and worked fine. probably me being a bit stupid!

    Edited once, last by viewinz (October 28, 2009 at 1:09 AM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!