SVG Icons not available on Firefox

  • I created a custom skin based on the default skin which uses svg buttons.
    On Firefox, these buttons are not available. Neither visible nor clickable. It works on all other brothers (mobile/desktop) though.

  • Hi,

    please have a look at Link .

    The problem are your SVG images, they don't have width/height defined and Firefox uses 0/0 as default in this case:

    See here:…l/SVG_Image_Tag

    Either try using an other SVG editor or other SVG export settings or add the width/height attributes manually in the SVG files.

    Best regards,

  • Hi Klaus,
    thank you for your hint.
    I was able to fix this.

    <svg xmlns="" viewBox="0 0 33.8 33.32" width="33.8" height="33.8">

    The viewBox attribute was already present. I added the width and height attributes. I needed to use a 1:1 ratio as I use this ratio for the layers (see xml snippet above).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!