Starting view bug?

  • Hi,
    I made minigame using krpano. But when I try it strange bug appear. One room ignore value for starting view but only when is VR view turn on. When using "normal view", everything works perfect. Just one room have this problem
    Please can someone help me?

    Here is link: http://static.pixelfederation.com/portal/assets/landing/colab/test2/

    Walkthru - turn light on and go forward. On first crossroad turn right and enter "wrong way" door... and next room is bugged one. If you using mouse+keyboard - starting view is ok. With VR device view - starting view setting is ignored.

    Thanks

  • Hello,

    In VR mode hlookat and vlookat don't work.

    Code
    <view hlookat="181.073" vlookat="3.204" fovtype="MFOV" fov="123.438" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto"/>

    You need to use the action lookat or resetsensor.

    https://krpano.com/plugins/webvr/#lookat

    Let me know if this works.

    Code
    <scene name="scene_f09" title="f09" onstart="resetsensor(181.073,3.204)" havevrimage="true" thumburl="panos/f09.tiles/thumb.jpg" lat="" lng="" heading="">


    Cheers,

  • Hello, thx for response... I try use both - resetSensor and lookat but nothing change :( Still same result... when I enter room with VR, initail view is wrong. If help here is xml for buged room/scene.

    Code
    <scene name="scene_f07a" title="f07a" onstart="resetSensor(1.482,6.531)" havevrimage="true" thumburl="panos/f07.tiles/thumb.jpg" lat="" lng="" heading="">
    
    
    		<view hlookat="1.482" vlookat="6.531" fovtype="MFOV" fov="123.438" maxpixelzoom="2.0" fovmin="70" fovmax="140" limitview="auto" />
  • Good one Alexey!

    Miglo, webvr_gyro_keeplookingdirection setting is only available in krpano 1.19.pr6 (and above), and I believe you're using 1.19pr5

    pixel.xml

    Code
    <!-- krpano 1.19.pr5 - Virtual Tour Skin -->

    You'll need to upgrade *cool*

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!