OSX VTour Droplet not working correct

  • Hallo Klaus, maybe you have an idea what to do:

    As in this 2 year old thread

    same happens now on both of my Mac systems
    (OSX Sierra 10.12.6 on macmini AND OSX 10.13.2 High Sierra on brandnew MacbookPro):

    Pulling 10 Panos - equirect., tif-pictures (from "cube to sphere") as well as pulling 60 cubefaces - tif-pictures (from "sphere to cube", worked on)
    on "MAKE VTOUR (MULTIRES) Droplet.app". Sometimes terminal starts and does 2-3 panos. Ignoring the rest. Rest even is not recognized by the system
    (in terminal app you can see a "processing 1/3..." - so not more than 3 panos where passed to terminal).
    If i try it again directly after that - it leads to sometimes no terminal app appears; the droplet itself starts and nothing happens.

    This is reproducable also using other droplets and
    the hint from the (unresolved) thread above - renaming the tif-files to tiff-files does not help either.

    krpano Version 1.19-pr14

  • Hi,

    are you really sure that you use the updated droplets from 1.19-pr14?
    This should be definitely solved there...

    The problem itself is an OSX bug - the system doesn't pass files that have a quarantine flag together with other files to a droplet.

    You could read about that problem also here (and also other many sites around the web):

    The new droplets are now using the workaround shown in the thread above - the droplets are not opening the dropped files the 'normal' way anymore, instead they are 'collecting' the files from several system calls and then process them together.

    If still not working (for reasons I don't know yet, maybe Apple has changed very recently again something - I will test this soon again) you could try removing the quarantine flag from all files that you want to pass to the droplets by using this terminal call:

    sudo xattr -dr com.apple.quarantine *

    Best regards,

  • Hallo Klaus

    Thanks for the quick response!!

    The droplets all are from the latest release (dated with Dec 1st 2017).
    So i tried to change the quarantine flag using your sudo command and it worked.

    ... seems that apple again changed something *cursing* .

    For the moment i am very happy with this solution - it´s no troublemaker anymore (just one command to execute) *thumbsup* *thumbsup*

    best regards,

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!